Table of Scenes & every possible story point on a single page

Could you make a screenshot of the table? Turn Elements of beforehand.
Then upload it here. That would help a lot in trying to fix the issue.

Sure, as you will see the inhibitor/cf don’t match with the story engine. Sorry to create this extra work for you. May I ask if you tried loading the casablanca file into the app at your end to see if it works differently on your machine?

Why didn’t you just say that Subjective Story, Main Character and Influence Character have the same Catalysts and Inhibitors? I fixed it now.

A post was split to a new topic: Network Map of All Storyforms

Finally got a little time to trial this but it appears that the link is down. I am getting a 404 error. Could someone point me to where it is live.

Really looking forward to trying this out.



I noticed a few days ago that Google stopped supporting its hosting feature.

For the time being, you can find the thing right here.

Thanks for finding another place to host it, Bob. This thing is so awesome.

One minor nit-pick – when you select the layman’s terms the Variation State of Being becomes “State of Playing a Role”.

(I actually prefer the original terms except for Preconscious, Subconscious & Conscious under Fixed Attitude, which still confuse me – maybe I’ll just edit the HTML after it generates it!. :slight_smile: )

All right, picked that little nit.

1 Like

Thank you! Very much appreciated!

Yes thanks!! Although there was a sort of Dramatica inside joke quality to the phrase “State of Playing a Role”! :slight_smile:

Where has this tool been the whole time? My Lord! This is awesome.

Hi All, sorry to be a bother but the Scenes generator isn’t providing the graphics of Z or U or anyother progressions. Any fix for it? Thanks.

  1. Since I’m the one who wrote the script and maintains this thing, it would be helpful if people used the mention feature @bobRaskoph so I notice it.
  2. Please provide more information than the problem. What browser (plus version) are you using? Do you have browser stuff disabled? Some browser cannot handle the graphics, which are generated during the process. Since I’m using a different host, I might just change those to actual images… But then you wouldn’t be able to save the whole thing as an HTML-file… I’ll have to think about it.

Thanks for the response @bobRaskoph . Your work is truly truly great. I currently use Safari version 9.0(11601.1.56). Its the same one I used when I got the the graphics. I also use El Capitan OS on my macbook pro. Thank you.

Hey @bobRaskoph! Love the tool. Thanks for creating it for the community.

The only trouble I’m having is with the Crucial Elements of the MC and IC. When comparing the tool’s output to dramatica’s character builder, the tool has the opposite dynamic pair as the Crucial Elements.

For example, within the provided image the Crucial Elements for the MC and IC are Order and Chaos, respectively; however, within Dramatica the Crucial Elements are listed as Inertia and Change for the MC and IC:

I’ve tested this out with another storyform and the CE inconsistency persists. Let me know if this helps!

Please send me a private message with both your story points output and the plot sequence report.
Then I might be able to clear this up.

@bobRaskoph I just signed up, so I don’t believe the messaging system allows outbound private messages for new accounts. I also tried to upload a pdf here, but it won’t permit it.


Hi! I’d like to start by saying thank you for making such a useful tool, and I’ve used it to great success, but I’ve just today run into an issue with it.

A few weeks ago I used it to great success in Safari ver 6.0 (8536.25) on a Mac build, but when I tried bringing it up today, I got some exposed javascript; it misfires right before “var textBlob” is declared and prints the remainder to the screen. I’ve checked and javascript was indeed enabled when running; the graphic I’m providing to show the exposed javascript was taken from a different browser, though, for convenience of sharing. (I’ve put the graphic in a details tag here, so hopefully it doesn’t gum anything up). [details=Error]


Now, I can get it to work in some Browsers, including Firefox and Chrome, but the output is missing the entire middle section. Image again in details tag. (Limited success in browsers Firefox 57.0.4 and Chrome 64.0.3282.167 on Windows 10). [details=Output]


Thanks for your consideration.

To be completely honest, at this point I see two options for this thing:

  1. drop it entirely
  2. redo it entirely

and the first one seems way more appealing to me at the moment.


  • if I redid it, this would be the third time coding this thing. It’s simply not that interesting to rewrite code, especially since it isn’t a very interesting problem to solve in the first place: turn plain text into a table.
  • it involves parsing text (1) copy-pasted (2) from another software (3). That’s thee red flags in one sentence right there.
  • I will have to keep all common browsers in mind this time to avoid these annoying inconsistencies
  • When I first did this, I was unemployed and depressed. Doing anything useful at all was a change of pace. Now I have a job, and I code every single day.

I mean, there is also the third option of just leaving it as it is, but letting this garbage code rot in the void just seems kind of wrong.

I haven’t made my decision just yet. I will have to think about all of this further. I’ll let you folks know when the time comes.

I have a cached local copy that still seems to work*, though I wouldn’t be willing to distribute it without Bob’s permission (it’s his software).

@bobRaskoph – if the local copy works, does that mean it’s a problem with your hosting? Anyway, I support whatever you choose since I’m still in awe of the incredible effort you put into this thing to begin with!

* Tested with Windows 7: Chrome 64, Firefox 59, Firefox 53.

EDIT: a little while ago I was getting the same error as @Jaybird on the live site, but that error seems to have gone away – it’s working.